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1. Overview - Database

When you acquire a large number of images with your software, it makes sense to
save them in a database. All of the file management functions, such as searching for
images, can be more quickly and easily used in a database than with files that have
been saved separately.

Your software offers a Client/Server-database for this purposes that is based on the
Microsoft SQL technology. Your software's database doesn't only save images, it also
saves all other types of file, for example, text files, and results sheets.

Which software version supports which database?

Note: You can only use the database if you have purchased a special Database
Solution together with your software.

The following Database Solutions are available:

The Solution Database Core Edition comprises the full database functionality. You
can create new databases and configure them to exactly suit your requirements. Make
use of the user management in order to assign access rights to individual users or to
user groups.

The Solution Database Client Edition offers limited database functionality. You can
open existing databases, search for records and load them, or you can insert new
records. You cannot create a new database.

About the database manual

The documentation is for database users as well as for database administrators. Since
database administrators have more rights to work with the database, not all of the
topics covered in this manual are equally relevant for all database users.

The topics about the user interface and the topics about working with the database are
for all database users. Therefore, it is assumed as a precondition that a database has
already been set up and configured.

The topics about configuring the database are only for the database administrator.

00061



2.1. Tool Window - Database - cellSens -

2.1. Tool Window - Database

The database will be displayed in the Database tool window. This tool window
provides you with access to all of the records contained in the database, and to
numerous functions you can use to work with your database.

Views in the database window

The Database tool window is divided into several areas. In each of these areas, a
special database view is displayed. You can adjust the size of these areas, in relation
to one another, however you want to. To do so, move your mouse pointer onto an
area's border in the Database tool window and move it while keeping the mouse
button depressed.
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The illustration shows the schematic make-up of the Database tool window when you all available
views are displayed. the tool window will then contain the following database views.

(1) Tree View: The Tree View shows all of the data that is present in the database. In
this view you gain a quick overview of how the database is structured.

(2) Gallery View: In the Gallery View, you will see thumbnails of all of the documents
that are to be found under the selected record. You select the record in the Tree View
(1).

You can also have the documents shown in the form of a table. The Gallery View will
then be replaced by the Table View.

(3) Record Details View: In the Record Details View, you will see information about
the currently selected record.

(4) Search View: In the Search View, you select search definitions that have already
been saved and carry out the database search with them.

(5) Image Preview: The Image Preview is used to display the image that has currently
been selected in the database gallery (2).



2. The user interface

Toolbars in the database window
The Database tool window contains two toolbars. These toolbars provide you with
access to the most important functions when you're working with a database.

Maximizing the database window

The Database window can, as the only tool window, be maximized. To do this, click
the Maximizel®l button. You can find this button in the tool window's header. This will
make almost the whole of your software's user interface available for displaying the
database.

Commands in an empty database window

When no database has been opened, the Database tool window offers you the
commands with which you can open a database, or set up a new database.

There, you can also find a list of the databases that were last opened. Simply click an
entry to open the corresponding database.
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2.2. Gallery View

In the Gallery View, you will see thumbnails of all of the images that are contained in
the database folder you have selected. Other documents (texts, MS-Excel sheets etc.)
will be displayed as an icon.

Where the Gallery View will be displayed in the database window, depends on the size
of the database window.

When the database window has been maximized, you'll find the Gallery View in the
center of the tool window. When the database window is very small, the Gallery View
will be arranged below the Tree View.

Making the Gallery View appear/disappear

[

1. Click the Open Database Views Menu button to open a list of all available
database views. You can find this button on the Database tool window's upper
toolbar.

2. Selectthe Gallery/Table View entry.
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+ When you do this, the Gallery View will either appear or disappear, depending
on whether it was already on display.

o Where the Gallery View will appear in the database window, depends on the
size of the database window.

3. When, instead of the Gallery View, a tabular view appears in the database
window, click with your right mouse button in the background of the Table View,
then use the Display Gallery command.

Setting the appearance of the Gallery View

Changing the size of thumbnails

You have the choice between two sizes of thumbnail. Right click in the background of
the Gallery View, and use the Small Thumbnail Images command, to switch
backwards and forwards between the two thumbnail sizes. When you use a smaller
thumbnail size you will be able to load far more documents into the Gallery View.

Altering the thumbnails’ labeling
You can set which database field is to be used for labeling the thumbnails. The record
name is, by default, used as labeling.

To do so, click your right mouse button in the Gallery View's background. From the
context menu, select the Customize Views command. In the Customize Views dialog
box, the Gallery View entry will have already become active, and you can select
another database field for the labeling.

The definition of database views is user-dependent. That means that a college who
opens the same database may well see other information.

Viewing information in the Gallery View

Which records will be displayed?
In the Gallery View, all of the records that are located within the database folder that
has been selected in the Tree View will be listed.

Which information will be displayed?

Select adocument in the Gallery View.

The Record Details View then shows you numerous database fields together with
their field values, for the selected record.

Showing quick info on the documents

When you move the mouse pointer over a thumbnail, an info window will open, in
which you'll find information on this thumbnail. You can specify exactly which
information will be shown. To do so, use the Customize Views dialog box, and select
the Tool Tip View entry in the View list.

Displaying a complete document path

Select a document and right click to open a context menu. Use the Copy Hyperlink to
Clipboard command in the context menu.

This command copies the complete document path, including the record name, to the
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clipboard. Use the [Ctrl + V] shortcut to insert the document path into e.g., any text
document you want.

Working in the Gallery View

You can carry out a number of actions in the Gallery View.

Selecting records

In the Gallery View, you can select several records simultaneously. For the selection
the standard MS-Windows conventions for multiple selection are valid. With the
multiple selection you can, for example, with one command, load several images into
the document group, or move them to another database folder.

Should the records you want to select be contained in different database folders, first
define a database search that will include all of the records. For example, search for all
of the images when you want to select specific images. When you carry out the
database search, the search results will automatically be displayed in the Gallery
View. Here, you can select the records you want.

Loading documents into the image preview

When you click once on an image in the Gallery View, the image will be loaded into the
Database tool window's Image Preview. The Image Preview provides more space on
the screen for image display than the Gallery View.

If you want to view an image in more detail, load it into the document group.

Loading documents into the document group

If you want to load an image into the document group e.g., to measure it, or to have a
more detailed look at it, select the image, then use the Load Documents command in
the context menu.

Alternatively, you can also double click the required document to load it.

Changing the default settings for the loading of documents

You can also alter the default setting that determines how a document reacts when
you double click it. To do this, use the Tools > Options command. Select the Database
> General entry. The When a document record is double-clicked list contains a
number of ways in which a document is to behave when a double click is used.

Sorting records

In the Gallery View, you can sort records in a variety of ways. Use the Sorting
command from the Gallery View's context menu to open a list with various sorting
criteria.

For example, select the Sort by Insertion Order sorting criterion. The last record in the
Gallery View is then the one that was last inserted.

Use the Sorting > Sort Manually command to move individual records by Drag&Drop,
within the Gallery View.

Opening the context menu
Select arecord in the Gallery View and click with the right mouse button. In this way,
you open a context menu that offers you a number of commands you can, e.g., use for
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editing this record. Here you will also find general database commands and
commands with which you can change the appearance of the database view.
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2.3. Tree View

The Tree View shows all of the records that are present in the database in a tree
structure. In this view you gain a quick overview of how the database is structured.

Making the Tree View appear/disappear

[

Click the Open Database Views Menu button to open a list of all available database
views. You can find this button on the Database tool window's upper toolbar. Select
the Tree View entry.

When you do this, the Tree View will either appear or disappear, depending on
whether it was already on display.

Viewing information in the Tree View

Making information on documents appear

Select any record in the Tree View.

The Record Details View then shows you numerous database fields together with
their field values, for the selected record.

Showing quick info on the documents

When you move your mouse pointer over an entry in the Tree View, an info window
will open, in which you'll find information on this record. You can specify exactly which
information will be shown. To do so, use the Customize Views dialog box, and select
the Tool Tip View entry in the View list.

Displaying a complete document path

Select a document and right click to open a context menu. Use the Copy Hyperlink to
Clipboard command in the context menu.

This command copies the complete document path, including the record name, to the
clipboard. Use the [Ctrl + V] shortcut to insert the document path into e.g., a text
document.
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Working in the Tree View

You can carry out a number of actions in the Tree View.

Browsing in the database
Double click on a database folder in the Tree View to expand the entry. Then all of the
records that lie under this folder will be shown.

As soon as you have selected arecord in the Tree View, all of the records that lie one
hierarchy level below the selected record will be displayed in the Gallery View or the
Table View. Images will be shown as thumbnails, other documents will be shown as
icons.

Loading documents into the image preview

When you click once on an image in the Tree View, the image will be loaded into the
Database tool window's Image Preview. The Image Preview provides more space on
the screen for image display.

If you want to view an image in more detail, load it into the document group.

Loading documents into the document group

If you want to load an image into the document group e.g., to measure it, or to have a
more detailed look at it, select the image, then use the Load Documents command in
the context menu.

Changing the default settings for the loading of documents

You can also alter the default setting that determines how a document reacts when
you double click it. To do this, use the Tools > Options command. Select the Database
> General entry. The When a document record is double-clicked list contains a
number of ways in which a document is to behave when a double click is used.

Moving records

There are several ways of moving documents within the database. In the Tree View,
you can move a document, e.g., an image, simply by Drag&Drop, into another
database folder. You can find more information on moving documents here.

Viewing search results
Inthe Tree View, you will also find the results of a database search. The Search
Results folder (2) is located on the same hierarchy level as the database (1).

When you expand the Search Results folder, you will see all of the search definitions
and search templates (3) that have previously been set up for this database. An icon
shows you which is a search definition and which is a search template.
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You can find more information on searching in a database here.
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2.4.

Opening the context menu

Selectarecord in the Tree View and click with the right mouse button. In this way, you
open a context menu that offers you a number of commands you can, e.g., use for
editing this record. As well as this, the context also contains general database
commands.

00307

Record Details View

In the Record Details View, you can for every record, view the way the database fields
have been filled out for this record.

Note: The Record Details View can't be displayed when the database window is very
small. Enlarge the Database tool window correspondingly. You will then find the view
either at the bottom left, or the bottom right, depending on how large the tool window
is.

Making the Record Details View appear/disappear

1. Click the Open Database Views Menu button to open a list of all available
database views. You can find this button on the Database tool window's upper
toolbar.

2. Selectthe Records Details View entry.
Should this command be displayed in gray, enlarge the Database tool window.

o When you do this, the Record Details View will either appear or disappear,
depending on whether it was already on display.

o Where the Record Details View will be displayed in the database window,
depends on the size of the database field.

Using the "Record Details" tool window.

For documents that you load into your software from the database, you can also use
the Record Details tool window as an alternative to the Record Details View. In this
tool window, all of the information will be displayed, that is also displayed in the Record
Details View.
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2. The user interface

In the Record Details tool window, there is normally much more room for the displayed
information, than in the database window.

In this case, you can make the Record Details View disappear from the database
window, and also gain more room for other views in the Database tool window.

Should the Record Details tool window be hidden, use the View > Tool Windows >
Record Details command to make it appear.

Customizing the appearance of the Record Details View

Y ou can specify which database fields will be shown. To help you keep a better
overview, you also distribute the database fields over several different groups.

To do so, right click one of the database fields in the Record Details View. From the
context menu, select the Customize Views command. In the Customize Views dialog
box, all of the necessary entries are then already active, and you can select the
database fields you want.

The definition of database views is user-dependent. That means that a colleague who
opens the same database with his password may well see other information.

Viewing information in the Record Details View

Displaying and modifying field values

Select arecord. You can select the record in the Tree View, Gallery View, or Table
View.

The Record Details View then shows you numerous database fields together with
their field values, for the selected record. Fields with a gray background serve only as
information. Fields with a white background can also be altered.

Please note that the database fields that are displayed depend on the type of record
selected. When you select a database folder you will see other database fields than
when you, for example, select an image.

Working in the Record Details View
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Modifying field values

Use the Record Details View to edit existing entries in database fields. You can,
however, only change fields which have a white background (2). Fields with a gray
background (3) serve only as information.

-12-
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Confirming the changes

As soon as you have changed an entry in a database field, the two buttons Confirm
Changes and Abort Changes will become active in the Record Details View toolbar
(1). Click the Confirm Changes button to have your changes adopted.

Expanding groups

To help you keep track of everything, you can assign the database fields to groups.
You can reduce every group in the Record Details View to its header. This enables
you to hide information that doesn't interest you. Double click on a group's header (4),
to reduce the size of the group, or to expand it again.

Opening context menus
The Record Details View offers you two different context menus.

Right click on a database field (5). This will open a context menu containing numerous
commands with which you can e.g., change the appearance of the database view.

Right click on an entry in a database field (6). This will open a context menu containing
numerous commands with which you can reformat the field entries.

00308

2.5. Search View
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In the Search View, you select search definitions that have already been saved and
carry out the search with them.

Note: The Search View can't be displayed when the database window is very small.
Enlarge the Database tool window correspondingly, when you wish to have the
Search View displayed.

2.5.1. Making the Search View appear/disappear
[ Click the Open Database Views Menu button to open a list of all available database

views. You can find this button on the Database tool window's upper toolbar. Select
Search View entry.
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2. The user interface

2.5.2. Working in the Search View

k 2]
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(1) List of all saved search definitions

In the Search View, you can find a list with all of the search definitions that have been
defined for the active database to the left of the Search button.

As soon as you have selected a search definition, the search conditions that have
been saved in it will be displayed in the Search View.

To define and to save search conditions as a file, use the Define Search dialog box.

(2) Carrying out a search
Click the Search button in the Search View to carry out the search.

The search results will be displayed in the Gallery View or in the Table View. Only the
records that fulfill the search conditions you've set will be displayed. When the (
[Organ] equals 'Liver' ) search condition has been selected, only the images of specific
samples, for example, will be displayed. Should a search not produce any records that
fulfill the search conditions set, the text There are no records to display will appear.

You will also find the results of a database search in the Tree View. There you will find
the Search Results folder (2) on the same hierarchy level as the database (1). When
you expand the Search Results folder, you will see all of the search definitions (3) that
have previously been set up for this database. An icon shows you which is a search
definition and which is a search template.
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(3) Using search templates

When you define a search condition, you can either define a concrete value or leave
the value as a variable. Where a variable search condition is concerned, the user has
to add the concrete value for which the search is to be carried out, before the database
search can start.

A search condition with at least one variable search condition is called a search
template.

A completely defined search condition is, e.g., ([Organ] equals 'Liver"). In this case you
are searching for all of the records in which, in the database field [Organ], the field
content 'Liver' has been entered.

A variable search condition is, e.g., ([Organ] equals '(variable)' ). Then, in the Search

-14 -
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View, the database field [Organ] will appear as the search condition. Later in the
Search View, the user then specifies for precisely which organ is to be searched.

00315
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3. Working with a database

3.1. Opening a database

When you want to work with a database, use the Open Database dialog box. You
have to open the database when you want to load documents (e.g., images, charts or
workbooks) that are contained in that database, or to insert new records into it.

Only one database can be opened at a time. As soon as you open another database,
the one that has already been opened will be automatically closed.

To be able to open a database, you must be registered as a user with the database
server. The database administrator takes care of that.

There are several ways in which you can open databases:

o Use the Database > Open command

o Use the File > Open > Database command.

e Onthe Standard toolbar, click the small arrow next to the Open button to open a
context menu with all of the available commands you can use for loading files.

¢ You canfind alist of the databases that were last opened, in the Database menu.
Simply select one of the databases that is listed.

« When no database has been opened, in the empty Database tool window, you'll
find a list of the databases that have recently been opened. Click the name of the
database you want, to open it.

Selecting a connection mode

When you want to open a database, you first have to register your PC with the
database server. The appearance of the Open Database dialog box depends on the
connection mode you have selected. Click the Options button in the Open Database
dialog box to select the connection mode.

Entering connection data manually

Click the Options button in the Open Database dialog box.

If you want to enter all of the information that is necessary for logging-on to a server
manually, select the Enter connection data manually option. Use this option when,
e.g., you only want to log onto a database on one occasion. To log-on manually, you
require the following information: the database management system, the name of the
database, and the name of the server on which the database is located. If you are not
certain about anything, contact your database administrator.

Close the Options dialog box with OK.

The Open Database dialog box will then contain the Database group.

Enter the name of the database in the Database > Database Name field. If a server
has already been selected, all of the databases that are on the selected database
server will be automatically listed.

Inthe Database > Server field, enter the name of the server on which the database
can be found. Should you not know the exact name of the server, click the [ ... ] button
to open the Select Servers dialog box. Select the server from the list of the available
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database servers, then click the Add >> button. Click the OK button to close the dialog
box, and to return to the Open Database dialog box.

Select the database management system in the Database > Database system list.

Using the database connection file

Click the Options button in the Open Database dialog box.

If you want to adopt all of the information that is necessary for logging-on to a database
from a text file, select the Use database connection file option. That will save you a
great deal of writing.

Close the Options dialog box with OK.
The Open Database dialog box now contains the Database connection file group.

Select the database connection file for the database you want to open, in the
Database connection file > File name list. By default, the database connection file that
was last selected will already have been preselected in the File name field.

Click the [ ... ] button if you want to open a database connection file that is not yet
present in the File name list.

You will see a description of the database you have selected in the Database
connection file > Description field. This short description must be entered by your
database administrator when the database connection file is set up. Should no short
description have been saved when the database connection file was set up, this field
will be empty.

User's details

With which authentication you need to log onto the database (either SQL or Windows
authentication) will have been determined when the database was set up.

Windows authentication

If you want to use the log-on data with which you are logged on to the MS-Windows
operating system also for logging-on to the database, select the Windows
Authentication entry in the User > Authentication list. In this case, you will neither need
to enter a password nor a user name.

If the database requires the Windows authentication for the log on, you will have to be
registered with your company's LAN (Local Area Network).

SQL authentication

Select the SQL Authentication entry in the User > Authentication list if you want to use
database specific log-on data. In this case, you will have to enter both your password
and your user name every time you log on. You obtain your password and user name
from the database administrator.

Using a database as a standard database

To turn the current database into a standard database, select the Use as standard
database check box.
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3. Working with a database

The standard database will normally be automatically opened when you start your
software. Use the Options > Database > Standard Database dialog box if you want to
change the way the standard database behaves when your software starts.

The settings for the standard database are user dependent. For this reason, another
user can have defined another database as a standard database.

5621

3.2. Inserting data into a database

You can insert two different types of data into a database.

D Structuring records
For the better structuring of a database, there are structuring record types, that are
indicated within the database by a folder icon. A record that belongs to this record type
isn't referenced to a document, but instead contains only the information that is
entered in the database fields. Use these records as a database folder. Create, e.g., a
structuring record "Experiment” with all of the information that describes the
experiment, then insert all of the images and reports that belong to this experiment,
underneath this record.

Documents

Documents are, for example, images, workbooks or diagrams.

You can of course insert all of the documents that you create with your software, or
load into it, into a database.

As well as that, you can, however, also insert any other files that have already been
saved on a data medium. That applies also to document types that are not supported
by your software, e.g., MS-Word documents with the file extension DOC.

3.2.1. Overview - Inserting data into a database

There are several ways in which you can insert data into a database. Use the
commands in the Database menu, or from various context menus, or click the buttons
in the Database tool window. You can also insert documents by Drag&Drop.

All of these possibilities will be described in the text that follows.

Menu commands
Use the Database > Insert menu commands. The following commands are available:

o Geodffnete Dokumente einfliigen

« Alle gedffneten Dokumente einfligen
o Dateien einfligen

o Strukturierenden Datensatz einfligen

[N
Buttons 1~ =
Use one of the buttons located on the Database tool window's upper toolbar.
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Context menu commands
Use the Insert menu in the context menu. You open this context menu by right clicking
on one of the following views in the Database tool window.

¢ Strukturansicht
o Galerieansicht
o Tabellenansicht

You can also insert a single document, for example, an image, directly out of the
document group into the database. Right click the document's title in the document bar
to open a context menu. The context menu will contain the Insert into Database
command.

Drag&Drop
Selectin MS-Windows Explorer, the files that you want to insert.

Drag the selected files from MS-Windows Explorer either onto the database icon, or
onto another record in the Tree View. The files are inserted below the record.

You can also drag the files onto the database gallery or the Table View. To do so, first
select the record in the database, into which you want to insert the document. Then
drag the document from MS-Windows Explorer onto the database gallery or the Table
View.

Inserting images automatically into a database
You can have images automatically inserted into a database when they have been
acquired. You can find more information on this topic here.

3.2.2. Notes on how to insert data into a database

When you insert records into a database, please pay attention to the points listed
below:

The database is structured hierarchically

You cannot insert records into every database level. When your database is based on
the database template provided, you won't be able to insert any data below images.
When you select an image, the data will be automatically inserted on the same
hierarchy level on which the image lies.

Inserting documents that have been changed

When you load a document from a database into your software, and edit it there, when
you close the document in your software, a dialog box containing numerous
possibilities, will open. You can replace the original document in the database, insert
the processed document as a new record, or save it as a file in any directory you want.

You can also change this behavior by altering the database's settings. Open the
Database > Settings > General > Other dialog box. Here, clear the Fields and records
> Allow replacing of documents check box.
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3. Working with a database

Now, the documents in the database can't be overwritten. If you want to insert a new
version of a document into the database, you will have to insert the new document into
the database under a new name, then delete the old document.

Moving images to another database folder

Should you once have inserted documents in the wrong place, you can retroactively
move them to the correct database folder by using the Cut and Paste context menu
commands.

00393 13102020

3.2.3. Inserting data into a database

Inserting documents into a database

You can insert all of the documents that you create with your software, or load into it
into a database. As well as that, you can also insert any other files that have already
been saved on a data storage medium.

In these step-by-step instructions, you insert documents that have currently been
opened in your software.

1. Open the database with which you want to work.

2. Load documents that you want to insert into the current database, into your
software. You can also create new documents. It doesn't matter whether the
documents have already been saved as a file or not.

Switch to e.g., the Acquisition layout, and acquire an image, or load an image from
your hard disk.

3. First, select the record in the database into which you want to insert the document.

o Please note that you cannot insert documents at every hierarchical database
level.

 When your database is based on the database template provided, you won't be
able to insert any documents below images. When you select an image, the
documents will be automatically inserted on the same hierarchy level on which
the image lies.

4. Use the Database > Insert > Insert Open Documents command.

o The Insert Open Documents dialog box opens. This dialog box lists all
documents that have been opened. The icon in front of the document shows
you what type of documentitis.

5. Inthe Insert Open Documents dialog box, you have to decide whether you want to
insert all of the opened documents into the database, or only some of them. Select
the check box in front of each of the documents you want to insert into the
database.

6. Click the OK button.

o The Insert <document type> dialog box opens for the first document you want
to insert. The dialog box's appearance depends on which type of document you
insert into the database.
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Enter all information into the insertion dialog that you want to have saved along with the record.

7. Check whether the document is going to be inserted into the correct record. In the
Insert into (1) group, the record into which the document is to be inserted will be
displayed.

Should you want to correct the higher level record, click the Browse button.

o The Insert Into dialog box opens. The Destination field gives you access to the
database's Tree View. Browse to the correct record, then confirm this with OK.

8. Inthe Permission Set (2) group, define who may see the document. For example,
if you select the Everyone entry, you will allow every user who can log onto the
database to view the image.

9. Enter the required information on the document in the database fields. Database
fields that are displayed in bold letters must be filled out. In some database fields,
e.g., the one for the record name, you'll be supplied with suggestions.

Case 1: Inserting information for every single document
10. Click the Insert button to save the current document together with the information
displayed in the database.

o The Insert <document type> dialog box for the next document opens.

11. Fillout the Insert <document type> dialog box for all of the documents.

Case 2: Inserting the same information for all documents
10. If you want to insert the same information for all of the documents, click the Insert
Allbutton.

 Allof the documents that have been selected are saved in the database one
after the other. The Insert <Document Type> dialog box won't open again.

o The database fields are filled out in the same way for all of the selected
documents. The information will be adopted from the first record.

When the documents have been inserted
« All of the documents that have been inserted have now been saved in the
database.

o The documents you have inserted will be displayed in the database window.
This process can, especially where large images are concerned, take some
time. The process is in progress as long as the mouse pointer remains in the
form of an hourglass.
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+ When an open document has been inserted into the database, it will still remain
open in the document group. Should you no longer need the image, close it
without saving it again.

o Should the inserted documents have already been saved as files: During the
insertion a copy of the file will be saved in the database. The files that have
already been saved won't be changed during the insertion in a database.

Inserting documents by Drag&Drop into a database

1.

Load or create documents that you want to insert into the current database, in
your software.

Make the Database and Documents tool windows appear. To do so, use the View
> Tool Windows command.

Position the Database and Documents tool windows in such a way that both tool
windows can be seen in your user interface at the same time.

In the Documents tool window, select the documents you want to insert into the
database.

Drag the selected documents from the Documents tool window onto the folder in
the database window into which you want to insert them.

You can also drag the documents directly onto the database icon. In this case, the
documents will be inserted on the database's top hierarchy level.

1 2

= - i
g 1

By holding down the left mouse button, you can directly drag images which are loaded in your
software from the Gallery (1) tool window to the Database (2) tool window.

Note: You can also insert documents into a database from the Gallery tool windows or
directly from MS-Windows Explorer using Drag&Drop.

Inserting new database folders

1.

By 2

Make sure that in the tree view no record in the Search Results database folder
has been selected, as otherwise the command will be inactive.

Click the Insert Record button. You can find this button on the Database tool
window's upper toolbar.

e Should several structuring record types have been defined in your database, a
selection menu will open. It contains the structuring record types that have
been defined for this database.
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3. Select the Folder entry.

4.

o The Insert Folder dialog box opens. The dialog box contains input fields for a
variety of database fields that relate to the database folder.

o The database fields that are to be filled out in the Insert Folder dialog box, have
been specified by the database's administrator.

o Some fields have to be filled out before you can set up the record. Those are
the mandatory fields that are displayed in extra bold type. Other fields that
belong to this record can also be filled out or altered later on, in the Record
Details View.

« Depending on the type of information you have to enter, you may be offered a
picklist, or a calendar field in which you can select a date.

Enter the name for the database folder in the Folder name field.

5. Fillout all input fields, then click the Insert button to set up the database folder.

¢ A new database folder will be set up. The database folder will be displayed in
the Tree View.

o Subsequently, insert the documents into this database folder.

Having images automatically inserted into a database when they
have been acquired

&

You can have images you have acquired with your software automatically inserted into
a database.

1.

Open the Acquisition Settings dialog box.
To open this dialog box, click the Acquisition Settings button. You can find this
button, e.g., on the Camera Controltoolbar.

Select the Saving entry in the tree structure.
Select the acquisition process for which you want to make the settings.

o Select, e.g., the Snapshot entry, when you want to have every image you
acquire, automatically saved in the database.

In the Automatic save group, select the entry Database in the Destination list.
Now, the image will be automatically saved in a database when it has been
acquired.

In the Database > Name list, select the database in which you want the images to
be saved.

e You can either choose a specific database, or always have the image saved in
the database that is open when the acquisition is made.

In the Database group, specify where the images are to be inserted in the
database, and who is allowed to view the images.

Close the Acquisition Settings dialog box with OK.

o From now on, all of the acquired individual images will be automatically saved
in a database.
00330 09012017
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3.3. Searching for records

You can search for data in your database at any time you want to. To do so, use the

Database > Define Search command or click the Define Search :N:J button. You can
find this button on the top toolbar in the database window.

When you search through a database, please pay attention to the following points.

o The database search will always be conducted through the whole database.

» You will find the results of a database search in the Tree View. There, you will find
the Search Results folder on the same hierarchy level as the database.

¢ You can make use of the results of different database searches.

Different search possibilities
There are always two ways to search for records.

o Searching directly for a record
If you only need a search definition once, specify the search condition with the
Database > Define Search command and apply it directly.

o Searchingin the Search View
If you want to use the same search definition repeatedly, save the search
definition and used these saved search definition in the Search View.

Before you start your search

Before you start a search it's advisable to update the view. By updating you will make
sure that all of the records will be found that at the time of the search are located in the
database. If you don't update the view, it can occur, that records that another user on
another PC, inserted into the database, shortly before the search began, won't be
found.

To update the view, use the Database > Views > Update Views command.

Searching directly for a record

1. Use the Database > Define Search command.
o The Define Search dialog box opens. You define the search conditions here.

2. Inthe Search for group, you can limit the search to a few record types. You can,
e.g., only search for images.

3. Define one or more search conditions in the Conditions group.
4. Click the Search button to start the database search.
o The Define Search dialog box closes.

e Inthe Tree View, your software will automatically switch to the Search Results
> Recent Search Results folder. The records that have been found will be
displayed in the Gallery or Table View.

o Should a Recent Search Results folder with the results of an earlier database
search already exist, the contents of this folder will be overwritten.

-24 -



3.3. Searching for records - cellSens -

Exiting the Search Results View
1. Selectarecord in the database gallery.

2. Click your right mouse button and select the Go To Record command in the
context menu.

¢ Inthe Tree View, your software will then automatically switch to the database
folder to which the selected record belongs.

Searching in the Search View

The Database tool window is divided into several areas. In each of these areas, a
special database view is displayed. In the Search View you can select predefined
search definitions with which you can carry out a database search.

In the step-by-step instructions that follow, it will be assumed that search definitions
that have been saved already exist.

1. Make sure that the Search View is on display.
To do so, click the Open Database Views Menu button to open a list of all
available database views. You can find this button on the Database tool window's
upper toolbar. The iconin front of the Search View command, must appear
clicked. You can recognize this status by the icon's background color.

2. Select the search definition you want from the list next to the Search button.

« When you open a database that has been set up with the template, which is by
default provided, numerous predefined search definitions will already be
available. For instance, select the search definition Find All Images to search
for all of the images contained in the database.

¢ Inthe Search View, the search conditions will then appear.
3. Should the search definition you've chosen contain variable search conditions:

Make the necessary entries for the variable search conditions. These are, as a
rule, different for every database search.

o The way you have to make the entries can also vary. You may be offered a
picklist, or a calendar field will appear in which you can select a date. Should
you be searching for a note, you may in certain cases have to enter the note
you're looking for (or a part of it) manually.

4. Click the Search button.

e The search will be carried out. The records that have been found will be
displayed, e.g., in the database gallery.

Saving a search definition for the database search

1. Use the Database > Define Search command.
e The Define Search dialog box opens.

2. Specify in the Search for group which type of record you want to look for.
For example, select only the Image check box to search it only for images.

3. Define the first search condition in the first line of the Conditions group. Your
search condition can, in this case, also contain a variable value. To do so, select
the (Variable) entry from the Value list.
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o As soon as you have completely defined the first search condition, an additional
line appears for an additional search condition.

4. If necessary, define an additional search condition in the second line. In this case
you will have to specify the logical link between the two search conditions.
To do this, select one of the logical operators AND or OR in the line's first field.

» With the logical operator AND, both of the search conditions must be fulfilled
simultaneously, in order for a record to be found with this database search.
With the logical operator OR, only one of the two search conditions has to be
fulfilled in order for a record to be found.

= S Save the search definition. To do so, click the Save Search Definition button in
the Define Search dialog box.

o The Save Search Definition dialog box opens.

6. Give it a descriptive name, so that you and other users will be able to easily
recognize the search definition.

7. Close the open dialog boxes.

» For every search definition that has been saved, an individual entry will be
automatically set up in the Search Results folder. In the Tree View, you will find
the Search Results folder on the same hierarchy level as the database.

« The database search will be carried out and the records that have been found
will be displayed in the Gallery View.

e You can now select the search definition in the Search View.
00312

3.4. Loading documents from a database

There are several ways in which you can load data from a database into your
software:

o Use the Database > Load Documents command.

o Drag one or more documents, e.g., from the Gallery View by Drag&Drop into the
document group.

o Double click on a document in the database to load the document into the
document group.
This behavior depends on the current settings in the Tools > Options > Database
> General dialog box.

Loading several documents from a database

This set of step-by-step instructions is only one example. There are several ways in
which you can load documents.
You will find notes on this, e.g., in the descriptions of the various database views.

1. Make sure that both the Tree View and the Gallery View are on display.

2. Inthe Tree View, select the record that contains the documents you want to load.

¢ Inthe Gallery View, you will now see all of the documents that are to be found
under the selected record. Images will be shown as thumbnails, other
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document types will be shown as icons.

e You can also load documents which are the results of a search. When, for
example, you want to load all of the images that were acquired with a specific
microscope, define a search definition using this microscope's name. The
images found will be displayed in the Gallery View. There, you can select the
images you want.

3. Select the thumbnails or the icons for the required documents, in the Gallery View.

In the Gallery View, the standard MS-Windows conventions for Multiple Selection
are valid.

Click the Load Documents button. You can find this button on the Database tool
window's upper toolbar.

o When your software can open a document, it will be displayed in the document
group.

 If your software can't open the document, the appropriate application program
is opened and the selected document is loaded into this program.
Should the appropriate application program not have been installed on your
PC, you will receive a message.
00313

3.5. Processing the documents from a database

Changing and adding to entries in database fields

[

When you set up a record, you already have to make entries in the mandatory fields.
You can supplement other entries later on.

1.

Make sure that the Record Details View is on display.
Click the Open Database Views Menu button to open a list of all available
database views. Select the Records Details View entry.

Inthe Tree View, Table View or Gallery View, select the record to which you want
to add information or change the existing information.

o The Record Details View shows you the information that has already been
collected for this record. If all of the fields that you want to edit aren't shown
there, you can customize this view.

¢ Inthe Record Details View, mandatory fields will be displayed in extra bold
type. You can change the contents of these fields, but the fields must not
remain empty. Fields whose content may not be changed (e.g., [Creation
Time]) will be displayed with a gray background.

Add to or change the entries relating to the record. Which fields you can edit, and
which you can't, depends on your database's structure.

e As soon as you have changed an entry in a database field, the two buttons in
the Record Details View's toolbar Confirm Changes and Abort Changes will
become active.

v X

Click the Confirm Changes button to have your changes adopted.
Click the Abort Changes button to abort the changes.
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o The record will be changed.

In any case, you must click on one of the buttons to confirm or discard your selection,
since your software will wait for input here.

Processing the documents from a database

You can, at any time, load a document that has been saved in a database, then insert it
back into the database.

1. For example, load an image from a database. To do so, e.g., double click on its
thumbnail in the Gallery View.
o The image will now be shown in the document group.

2. Process the image in your software. Your software offers you numerous
possibilities for doing this. Here are a few examples:

o Forexample, use the commands in the Process menu to optimize the image
contrast.

o Use the buttons in the Drawing toolbar to label the image.
¢ Use the commands in the Measure menu to measure objects on the image.

3. When the processing is finished, close the image in the document group. To do
this, use e.g. the [Ctrl + W] shortcut.

o A dialog box offering several possibilities opens. You can replace the original
document in the database, insert the processed document as a new record, or
save it as a file in any directory you want.

4. From the dialog box's list, select, e.g., the Paste entry, then confirm this with OK.

e The altered document will then be inserted into the database, and will replace
the original document. When this is done, the original document will be
overwritten.

o The information from the database fields will be adopted from the original
document without any inquiry being made.
00065

3.6. Moving documents within a database

Moving documents within the database hierarchy

Should you have inadvertently inserted documents into a false database folder, you
can move them from there to the correct folder.

Moving documents by using commands from the context menu
1. Select the documents you require in the Tree View, Table View or Gallery View.

e Inthe Gallery View, you can select several documents simultaneously. To do
so, keep the [Ctrl] key pressed while you select the documents.

2. Click the right mouse button to open a context menu. From the context menu,
select the Cut command.

-28-



3.6. Moving documents within a database - cellSens -

3. Select the record into which you want to insert the document. You have to always
select the record that is located one hierarchy level higher.

4. Click the right mouse button to open a context menu. Select the Paste command
from the context menu.

e« The document is moved.

Moving documents by Drag&Drop
Alternatively, you can also move a document by Drag&Drop.

1. Select the documents you require, in the Tree View or in the Table View or Gallery
View.

2. While keeping your left mouse button depressed, drag the document onto the
record into which you want to insert it. You can also do this by dragging the
document from the Gallery View to the Tree View.

e« The document is moved.

Moving documents into another document directory

Atthe end of the year, all of the records that were inserted into the database during the
year 2010, are to be moved to a document directory of their own.

Defining a suitable search definition
1. Use the Database > Define Search command.

e The Define Search dialog box opens.

2. Click the Select Allbutton to find all of the records, irrespective of their record type.

3. Define the following search condition in the Conditions group.
[Insertion date] >='01.01.2010"' AND [Insertion date] <'01.01.2011'

o Now, all of the records that were inserted into the database during the year
2010 will be found.

= 4. Save the search definition. To do so, click the Save Search Definition button in
the Define Search dialog box.

o The Save Search Definition dialog box opens.

5. Enter"2010"in the Name field.
6. Close the open dialog boxes.

Selecting a search definition
7. Use the Database > Administration > Move Files command.

o The Move Files dialog box opens.
8. Selectthe From saved query '2010'in the Files to be moved'list.

« Inthe Description field, you'll now see the search condition. Check whether the
search condition is correct.

Selecting a search definition
9. Click the Settings button.

10. Select the Document Storage Type > File System entry in the tree view.
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"/I 11.

12.
13.

14.

15.

Click the New Volume button to integrate a new document directory into the
database.

o The New Volume dialog box opens.

Enter "2010" in the Description field.

Set up the path name for the document directory.

When you do this, please note that the document directory has to be available to
all users when you want to continue to work with the database in the way you're
used to.

Select the Archive entry in the Media Type list. By doing this, you indicate that the
new document directory "2010" has been finalized. No additional records can then
be inserted into this document directory anymore.

Close all open dialog boxes with OK.

o Your software will then move all files belonging to the selected records, into the
document directory "2010".

+ When the movement of these files has been successfully completed, a
message appears.

o Evenwhen the records have been moved, you can still work with these records
as usual within the database. The prerequisite for this is, of course, that the
new document directory is available to all users.

e You can now, for example, copy this directory onto a DVD.

00090

3.7. Importing and exporting data

Exporting a database's structure

It can make sense to export a database's structure in order to use the database export
file (DBE file) that has been created as a template for a new database that is to have
the same structure.

1. Open the database you want to export.

Use the Database > Import/Export > Export Database command.
o The Export Database dialog box opens.

Assign the DBE file a name.

Specify the location at which the DBE file is to be saved.

In the Options group, select which data are to be exported from the database.
Select, e.qg., the Export structure only (database template) option when you want
to create a template for a new database.

Click the OK button to start the export.

o The Logging tool window will automatically appear. Here, you will see which
data are currently being exported.

» When the export has been completed, a message box will appear. Additionally,
you'll see a corresponding notification at the end of the list.
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o With that, the export has been completed. You can then carry on working with
the current database as usual.

7. Use the Database > Import/Export > Import Database command when you want

to set up a new database on the basis of the exported DBE file.

Importing data into a new database

You can import data from another database into your database. The prerequisite for
this is that both databases have the same database structure.

1.

Use the Database > Import/Export > Import Database command.

e The dialog box opens.

Click the Browse button and navigate to the directory in which the DBE file
(Database export file) is located.

Select the data you want to import.

o Selecte.g., the Export structure, users, and structuring records option. Now,
the complete contents of the DBE file will be imported (that means, also
documents, should the DBE file contain documents).

Click the OK button to start the import.

e The Logging tool window will automatically appear. Here, you will see which
data are currently being imported. The importing process can, when
documents are also imported, take some time. Therefore, keep an eye on the
information in this tool window. When the importing process has been
completed, you will see a corresponding message at the end of the list.

e You can then begin to work with this database.

Exporting documents from a database

You can export individual documents from a database. In this way, you can, e.g., make
images available to users who have no access to the database. When you export a
document, you make a copy of it. This means that the original documents in the
database will be retained.

1. Select the records you want to export.

Use the Database > Import/Export > Export Documents command.
o The Export Documents dialog box opens.

« ltis essential that you keep an eye on the display at the bottom of the dialog
box. It shows you the amount of data that is going to be exported.

Make the required settings in this dialog box.

Select the Reproduce database structure in file system check box to maintain the
record's hierarchical structure. A directory will be set up on the hard disk for every
database folder in which there are files. This directory's name is also the name of
the record.

Click the [ ... ] button next to the Destination path field to choose the directory into
which the data you export is to be saved.

Click the OK button to start the export.
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o The export begins. The documents in the database will be retained.

00320
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4.1. File storage in a database

When you set up a new database, you specify where the database files and the
images, (and other documents) are to be saved. The data can be distributed as shown
in the illustration.

1
E 2 3
g-a-
.li caaos

(1) Database clients

The database clients are all PCs on which your software and an SQL client have been
installed. Your software offers (among many other functions), the user interface that
enables you to communicate with the database server.

For viewing or editing, the requested data will be transferred to the database client.
This makes it possible for numerous database clients to have access to the database
at the same time.

(2) Database server

On the database server, the database management system (DBMS) has been
installed.

On the database server lies, first and foremost, the actual database file. When you,
e.g., insert an image into the database, in doing so, you create a new record of the
"Image" type in the database. This new record will then be saved and managed in the
database. The database assigns this record an unambiguous name and saves all of
the corresponding information belonging to it (e.g., the insertion date, the file size or a
comment on the record). The management of these metadata by the database
enables the user to search the database for records that meet the search criteria he
has specified.

Note: Images (or other documents) will not be saved within the database. Otherwise
the database file would become much too large. The database file contains only the
reference to the place where the image has been saved.
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4.2.

(3) File Server

The images and other documents are located in special file directories.

Please note: The PC on which a database's documents are located must always be
accessible. Should this not be the case, you will receive an error message when you
try to load a document from the database.

The documents are usually located on a separate PC, the so called File Server. When
you connect with the File Server you can view the document directory in MS-Windows
Explorer.

You can also distribute your documents over different file servers. Use this possibility,
for example, to increase the speed of data transfer when users access the database
from different locations.

Use the Settings > Document Storage Type > File System dialog box to manage your
database's document directories.

Please note: Always open all documents that have been saved in the database, via the
database, and not via the MS-Windows Explorer! Also the deleting or renaming of
documents that are located in the document directory must not be done via MS-
Windows Explorer, since in this case the database will not become aware of these
changes.

00328

Setting up a new database

Only the database administrator can set up a database.

Overview of the process flow when a database is set up
The following steps have to be taken when a new database is set up.

Setting up a new database

v

Defining record types

\4

Defining the database structure

v

Setting up database fields

Setting up a new database

1. Selectthe Database > New command.
o The New Database dialog box opens. This dialog box works in a similar
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manner to a wizard. It guides you step-by-step through the setting up of a
database.

Step 1: Selecting the database server
2. Specify inthe Database Server field, on which database server the database is to
be set up. If you have already set up a database on this server from your PC, you
will find the required server in the picklist.

o Alternatively, click the [ ... ] button. The Select Servers dialog box opens. Here,
select the server from the Available database servers list, then click the Add >>
button. Click the OK button to close the dialog box, and to return to the New
Database dialog box.

o Onthe database server, the database file is located. The documents e.g., the
images, can also be located on another PC, or even on several different PCs.

¢ You can find more information on document storage in a database here.

3. Inthe User Authentication group, you select the way you (and all future users) are
to log on to this database.
Select the Windows Authentication entry. With Windows Authentication the data
with which the user logs on to MS-Windows will also be used for logging on to the
database.

« Alternatively, you can also select the SQL Authentication entry.
With the SQL Authentication the logging on data that have been defined for the
Microsoft SQL Server will be used. Every user of your database must know
these logging on data (they are supplied by the database administrator) and
has to enter them in the User Name and Password fields to be able to open the
database.

o Thefirst step in setting up a database has now been completed.
4. Click the Next > button.

Step 2: Entering the name of the database, and specifying the storage
location for documents
5. Enter the name of the database in the Database Name field. The name must not
be longer than 20 characters and must not contain any spaces or special
characters. Under this name you'll find the database, in the Open Database dialog
box.

6. Ifthe new database is to become your standard database, select the Use as
standard database check box. This option makes sense when you mostly work
with the same database.

o Later onyou canthen use the Tools > Options > Database > Standard
database command to specify that the standard database will be automatically
opened whenever you start your software.

7. Enter the directory in which the documents are to be stored. To do so, clickthe [ ...
] button next to the Document Storage Path field, then browse to the directory you
want to use.

Note: When several people are to work with the database, select a directory which is
also available to other users of this database.
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If you're the only user of the database, you can also choose a local directory on your
own PC.

Note: To have your database with all of its documents regularly saved, make sure that
both the database server, and the PC on which the documents are stored, are
incorporated in an automatic data back-up process (e.g., every night).

8.

9.

When you work with several databases, enter a descriptive text for the new
database, in the Database Description field. This text will later be displayed in the
Open Database dialog box (if you use the Use database connection file
connection mode).

Click the Next > button.

Step 3: Selecting a database template

10.

11.

12.

13.

In the Template File Path field, choose a database template. A database template
has the file extension DBE.

A database template already contains a defined database structure. It may
possibly also contain documents that you can incorporate in your database as
well.

o Your software will have been supplied with a database template. During the
software installation, the template is installed in the following directory:
.A\Documents and Settings\All Users\Application Data\Olympus\OSIS\ <Name
of your software>\Database\DBE

Select the Create an empty database option, if you only want to adopt the
database structure from the database template.

You can set up your database on the basis of a template that was provided, then
modify the structure to suit your requirements.

Click the Next > button.

o The wizard's next dialog box shows you all of the options that you have set up
for the new database.

Step 4: Checking the options for the new database

14.

16.

Check the options for the new database.
If you want to correct a setting, click the underlined terms. For example, click the
term "Database Name", if you want to change the name you've entered.

« Should you want to change an option, your software will jump back to the New
Database wizard's corresponding dialog box.

Click the Finish button to have the database set up.

e The Logging tool window will automatically appear. In it you can follow the
setting up of the new data.

o When a database is set up, a database export file (DBE file) will be
automatically created. You can use this DBE file as a template for your next
database.

o When a database is set up, a database connection file (DBC file) will be
automatically created too. The database connection file makes it possible for
you to quickly log on to this database in the future. You can find the DBC file in
the following directory:

...\Documents and Settings\All Users\Application Data\Olympus\OSIS\
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<Name of the software>

+ The database will be set up and opened. You can see the database in the
Database tool window.

17. You now have to configure the new database.

Defining record types

The database is structured hierarchically. Structuring Records are records on the
highest hierarchy level, they are displayed in the structure view with a folder icon.
Structuring records aren't referenced to documents, they contain only the information
that has been entered in database fields.

When your database is based on the provided database template, it will contain just
one structured record type, with the name "Folder".

Example: You want to always assign the data in your database to a specific
experiment. Create the new record type, "Experiment".

1. Use the Database > Administration > Define Record Types command.

e When you define record types, you change the database structure. That is only
possible when the database has been opened in the exclusive mode.
When the database hasn't been opened in the exclusive mode, a message
box, in which you can activate the exclusive mode, will open.

o Tothe left of the Define Record Types dialog box, you can find a list of all
record types that have been defined in the current database.

» One or more field tables have been assigned to each record type. A field table
is a group of database fields that characterize the record type in detail.

Setting up a new record type.
2. Clickthe New Record Type button.

* A new entry will be attached to the list of record types.

3. Enter the name of the new record type, in this example, "Experiment", and confirm
this with the [Enter] key.

o Tothe new record type "Experiment" the field tables, "Record Fields" and
"Folder Fields" will be automatically assigned.
The "Record Fields" field table contains general database fields, that are valid,
irregardless of the record type, for every record. To these records belong, the
record name, the setting up time (i.e. the time a record was inserted into the
database), and also a field for comments.

Defining database fields for the new database
4. Click the Fields button.

o The Define Fields dialog box lists, on the left, all of the field tables that have
been defined in the current database. You'll also find the new field table
"Experiment Fields" there.

5. Select the "Experiment Fields" field table.

o The "Experiment Fields" field table contains only one single database field, the
"Experiment Name" database field:
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6. Double click the "Experiment Name" database field. Set up all of the required
options for this database field, in the Edit Field dialog box. You can, e.g. define a
picklist.

7. Define additional database fields in the "Experiment Fields" field table, e.g.,
[Sample], [Client].

¢ You can find step-by-step instructions on how to define new fields here.

8. Close all open dialog boxes.

Assigning user groups
e The Assign Configuration to Users dialog box opens.

9. Decide whether all of the database's users are going to be allowed to use the new
record.

Since in this case, every record is to be assigned to an experiment, select the user
Everyone then close the dialog box with OK.

¢ Your database now contains the structuring record type "Experiment".

e Inthe Database > Insert menu, you'll now find the Experiment command. Use
this command to set up a new database folder for the data of an experiment.

Using a new record type
10. Use the Database > Insert > Experiment command

e Theinsertion dialog now contains all of the database fields that you have
defined for the "Experiment Fields" field table.

» As your next step, you should change the other database's views. To do so,
use the Database > Views > Customize Views command. Then specify for
each record type, and for each view, which fields are to be displayed.

¢ You can find a step-by-step instruction for doing this here.

Defining the database structure

When you define the database structure, you specify which data you can insert under
specific record types.

Example: Define a database structure with precisely two hierarchy levels. Prerequisite
for this is, that you have defined two structuring record types, e.g., "Project" (1) and
"Operator" (2). In this case, you can insert all of the data on a project into the project
folder. Each operator must, within the project folder,set up his own folder, into which
he inserts his project data.

e
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1. Open the database in the exclusive mode.
2. Use the Database > Administration > Define Database Structure command.
o The Define Database Structure dialog box will appear.

You always make the definition of the database structure in the right-hand half
of the dialog box. The left-hand side shows the current database structure, you
can't change anything there.

3. Specify for every record type, which record types are allowed to be underneath it.

i First, select the Database entry from the Record type list. This entry stands for the
topmost hierarchy level in every database.

4. Inthe Accept as child record list, select which records are allowed to be
underneath the topmost hierarchy level.
In this example, only the structuring record type "Project” is to be found
underneath the database icon (1).
To do this, select the check box in front of the record type "Project", and clear all of
the others.

5. Now select the next record type in the Record type list. In this case, select the
record type "Project".
Then specify again in the Accept as child records group, which record type is
allowed to be underneath it, and clear all of the others. In this case, only the record
type "Operator" (2) is allowed.

6. Now select the next record type in the Record type list. In this case, select the
record type "Operator".
In the Accept as child records group, select the check boxes Chart, File, Image
and Workbook, and clear all the others.
By doing this, you specify that documents can be inserted underneath a record of
the "Operator" record type.

7. Check whether the database hierarchy in the left-hand area of the dialog box is
correct.

8. Close the Define Database Structure dialog box with OK.

o You will be asked if you want to leave the exclusive mode. You can answer this
question with yes, since the definition of the database has been completed.

9. Check the database structure. To do this, insert an example of each of the record
types you have defined into the database.

+ When you are satisfied with the database structure, you can begin working with
this database. Alternatively, you can now, or at a later point in time, change the
database structure.

o Consider whether you want to export this database structure as a template, to
be able to use it again later on. To do so, use the Database > Import/Export >
Export Database command.

Setting up database fields

You can define which ever database fields you want that the database user can fill out,
or must fill out, when he sets up arecord in the database.
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Example: You want to make it possible to enter the laboratory name as well, when an
image is inserted. To do so, set up the database field [Laboratory No].

1.
2.

10.
11.

12.

Open the database in the exclusive mode.
Use the Database > Administration > Define Fields command.

o The Define Fields dialog box opens. There, you will find all of the database
fields that are already defined in your database. Every database field it contains
is allocated to a group, and a group of database fields is called a "field table".

From the Field tables list, located in the Define Fields dialog box, select the field
table to which, according to its contents, the new database field belongs. In this
example, you're only interested in images. Therefore, select the Image Fields
entry. When you want to enter the laboratory designation for all of the records,
you'll have to select the Record Fields field table.

o Inthe Fields list, all of the database fields will then be listed that belong to the
Image Fields field table. This field table contains database fields that are
especially related to images.

. Clickthe New Field button. You'll find this button above the table with the

database fields.
o The New Field dialog box opens.

In the Name field, enter a name for the new database field.
Enter, for example Laboratory No if you want the laboratory name to be entered
and saved for every image.

In the Data type list, select the Text entry for the new database field.

Enter the maximum number of characters that can be used in the database field,
in the Size field.

For example, enter 10 when your laboratory name is to be made up of a maximum
of ten characters.

In the Default group, you determine how the field is to behave when a new record
is inserted.

For example, select the first option and leave the field empty to define no default
value. The database field will then be empty every time you make an insertion,
and will have to be filled out.

Clear the Input required check box.

This will mean that the field can also remain empty when a record is inserted.
When you select this check box, no image can be inserted into the database,
unless the laboratory designation has been entered.

Select the Editable check box. Otherwise you will have to define a picklist.

Click the OK button to adopt your settings and to return to the Define Fields dialog
box.

o The new database field will now be shown in the Fields list, under the Image
Fields field table's already defined database fields.

Close the Define Fields dialog box with OK.

¢ You will then receive the query whether you want to make the changed
database views available to all of the database users, or not.
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13. Confirm the message with Yes.

o The Assign Configuration to Users dialog box opens.
When all of the database's users are to be able to view the new database field
in the insertion dialog, select the check box in front of the Everybody entry, then
confirm this with OK.

14. Insert an image into the database.

e The new database field will appear in the Insertion dialog box.

» As your next step, you should change the other database's views. To do so,
use the Database > Views > Customize Views command. Then specify for
each record type, and for each view, whether the new database field is to be
displayed or not. You can make the database field appear, e.g., in the Record
Details View, to be able to immediately see the operator for every record.

¢ You can find a step-by-step instruction for doing this here.

00097

4.3. Changing the database view

The Database tool window is divided into several areas. In each of these areas, a
special database view is displayed. In the following, you can find a description of the
procedure for changing a database view.

When you change a database view, these settings are only valid for you. With other
users, the database views will not be changed.

Changing the database view

1. Use the Database > Views > Customize Views command.

o The Customize Views dialog box opens. A detailed explanation of this dialog
box can be found here.

2. Select the database view and the record type you want to change, in the Selection
of views and record types group.
3. Make the required changes. You have the possibilities that are given below. Not
every possibility is available for every database view.
o Adding additional database fields to the database view
» Hiding database fields that are present in a database view
» Changing the order in which the database fields are displayed
e Grouping database fields
o Deleting a group
e Changing the group's name

4. To adopt your changes, click the OK button.
« The changed database view will be displayed.
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Adding additional database fields to the database view

1. When the Selected fields list contains several groups: First, select the group to
which the database field is to be added.

% | &
1 =

E ]

¢ Inthe dialog box, a group is indicated by a directory icon (1).
In the example shown, two groups, each with three database fields, are on
display in the database view that has been chosen (2).

2. Inthe Available fields group, specify how the database fields are to be displayed in
the Customize Views dialog box.

= « If your database doesn't have too many fields, click the Flat View button to
have all of the database fields listed, one under the other.

3. Select one or several database fields in the Available fields list. The standard MS-
Windows conventions for multiple selection apply.

e The Select >> button will become active.
4. Click the Select >> button.

o The database fields you've selected are added to the bottom of the Selected
fields list.

5. Should you want to, you can move the database fields you've added, by
Drag&Drop, to another position within the group.

Hiding database fields that are present in a database view
1. Select the database field in the Selected fields list.
2. Click the << Remove button.

« The database field will be moved into the Available fields list. From then on, it
won't appear in the selected database view.

o The database field will only be removed from that view. The database field, and
all of the entries in this database field, will be retained.

Changing the order in which the database fields are displayed

1. Select the database field in the Selected fields list.

2. Click the buttons with an arrow on it. With one mouse click you will move the
database field by one line upwards or downwards.
Alternatively, you can also move the database fields by Drag&Drop.
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Grouping database fields

You can decide whether all of the database fields that have been selected in a

database view for a certain record type, are to be displayed in one group, or in several
groups.

= 1. Togroup database fields, set up a number of folders in the Selected fields list. To
do this, click the New Group button.

o The new group is set up in the Selected fields list. You can enter the name
directly when you set it up. However, you can change it later whenever you
want to.

2. Move the required database fields into the new group by Drag&Drop.

3. Should you want to add database fields that have not yet been displayed to the
group, select them in the Available fields list, then click the Select button.

4. Close the Customize Views dialog box with OK.

o When several groups have been defined, you can, for example, minimize one
group, and in this way gain more room on your screen. Distributing the
database fields over several groups is especially advantageous where images
are concerned, since there, a very large number of database fields may be
displayed.

Deleting a group

1. Should there be database fields in the group that is to be deleted, that you want to
continue to display, simply move them by Drag&Drop into another group first.

“ 2. Then select the group, and click the Delete Group button.

» All of the database fields belonging to the deleted group will be moved back into
the Available fields list.

3. Close the Customize Views dialog box with OK.

Changing the group's name

1. Todothis, click once on the group to select it.
e The group's name will then be highlighted in blue.
2. Click on the group once more.

* Now, the name will be editable. You will recognize this by the black frame
around the group's name and by the form of the cursor.

3. Enter the new name, then press the [Enter] key.
e The new name will be displayed.

00319

4.4. Managing user rights

When you set up a new user for a database, you can assign him one or more roles.
When the user has more than one role, either one role will be assigned as default role,
or, whenever he logs on to the database, he will be asked which role he wants to use.
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The role he chooses determines which rights the user has to view or change data in
the database. The functions that are linked to each role are predefined and cannot be
changed.

Which roles are there?

Guest
Guests can read the records that have been assigned to the Everyone group. They
can neither change the database nor manage user rights.

User

Users can by default read and update their own group's records, insert new records
into this group, and delete records. They aren't allowed to view or change any other
records. They can neither change the database structure nor manage user rights.

Power User

Power Users are allowed to do everything that users are allowed to do. Additionally
they are allowed to change the database structure. However, as Power User they
can't change user rights. The moving of records is also only possible as database
administrator.

Administrator
Administrators have full access to the database. As well as that, they are allowed to
manage the database's user rights.

The administrator for your database need not be the administrator for your operating
system or your software.

0032521062011

£ User Accounts

Use the Database > Administration > User Accounts command to define user profiles
and user groups for the current database.

Prerequisites for setting up of new users or user groups
You can set up user profiles and user groups in the database. To make this possible,
both of the following prerequisites must be fulfilled.

e You must have administrator rights for the database. If it was you who set up the
database, you will automatically have administrator rights.

 Allof the users who you want to add to the database must have already been
registered with the DBMS (Database Management System, e.g., Microsoft SQL-
Server 2017 Express). This is a task for the DBMS administrator.
Should you be the DBMS-Administrator yourself, you can set up a new database
user in the DBMS via your software. If you have installed the Microsoft SQL server
together with your software, then you'll automatically be the DBMS administrator.

Which users and user groups does a new database have?

By default, a newly set up database will always have at least one user, namely the
person who set it up. This user will have Administrator rights. By default, the Everyone
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user group will also be set up. This user group can't be deleted or manually edited. The
Everyone user group will be automatically updated when new users are added or
users are deleted. This procedure will ensure that a user group that incorporates all of
the database's users always exists.

5632

Setting up a new database user

Let's assume that your company has employed a new employee who is to have
access to the database. Before this person can open the database, the database
administrator must register the new employee in the database.

1. Use the Database > Administration > User Accounts command.
¢ Inanewly set up database, there will always be at least one user, namely the
person who set it up. Additionally, the Everyone user group will always be set
up.
o Inthe User Accounts dialog box. all of the existing users and user groups will
be listed.

Adding users
2. Click the Add User button.

o The Add User dialog box opens.

3. Click the Browse button.

o The Select Database Server User dialog box appears. Here, all of the users
who are registered in the DBMS are listed. Should you be the DBMS
administrator, you can also register a new user in the DBMS there. To do this,
click the New button.

» Should the user you want not be listed there, and you are not the DBMS
administrator, apply to the DBMS administrator.

 If you know which users are registered with the DBMS (e.g., because the
DBMS administrator has given you a list), enter the user's name in the User
name field, then click the Next > button.
Then continue with the "Assigning user properties" step.

4. Inthe Select Database Server User dialog box, select the required user, then click
the OK button.

o You will then see the Add User dialog box once more.

5. If youwant to, enter a description of the new user in the Add User dialog box, then
click the Next > button.
This description appears in the User Accounts dialog box, and can help you to
keep track of all of the users.

o The User Properties dialog box will appear. In it, you will see that the new user
has been automatically assigned to the Everyone user group.
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Assigning user properties

6. Should you want to, assign the user to additional user groups, then click the Next
> button.

o The next dialog box shows the possible roles the new user can be assigned. A
user has to be assigned at least one role. This determines which rights he has
to view certain database records.

7. Selectthe role the user is to be assigned. You can also assign a user several
roles.

¢ You can find a description of the possible roles here.

8. If you assign the user more than one role, select the Prompt for role selection at
login check box. Only in this case will the user be asked which role he is going to
use when he logs on to the database.

If this check box hasn't been selected, the user can't choose his role, but always
starts with the role that has been defined as the default role. Only the
administrator can assign this user another default role.

9. Clickthe Finish button.

o The User Accounts dialog box appears again. The new user is now shown in
the user list.

10. Ifrequired, add more users to the database, or close the dialog box with OK.

Informing the user
11. Then inform the user.

 Inform the newly added user that he now has the right to open this database.
e Send him alink to the DBC file.

» Should you have newly set up the user in the DBMS, inform him which user
name and which password (including the case sensitivity used) he is to use
when he logs on to the database (when it's a database with SQL
authentication).

Whether the user will be able to change this password later on depends on the
options offered by the DBMS. In certain cases, passwords can only be
changed by the DBMS administrator.

Setting up a new database user in the database and the DBMS
simultaneously

If you are yourself the DBMS administrator, and have logged on to the database with
the administrator password, you can set up a new database user in the DBMS via your
software.

1. Usethe Database > Administration > User Accounts command.

2. Clickthe Add User button.

3. Click the Browse button.

e The Select Database Server User dialog box opens. The required user does
not appear in the List of Users field.
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4. Click the New button.
o The Add New Database Server User dialog box opens.

5. Enter the user name and assign a password for him. Select the authentication
SQL Authentication.

6. Click the OK button.
e The newly set up user will then appear in the user list.

Changing the rights of an existing user in the DBMS

Prerequisite: Your are the DBMS administrator and are logged in to the currently
opened database with the administrator password.

You can edit the DBMS rights of an existing database user with your software. You
can permit a user to set up new databases and/or to define new users in the DBMS.
These rights apply for the DBMS and are not effected by which database is currently
opened or which of your software's work stations is being used.

1. Use the Database > Administration > User Accounts command.

o Inthe User Accounts dialog box. all of the existing users and user groups will
be listed.

Selecting a user
2. Select the user whose rights you want to change in the DBMS.

3. Click the Properties button.
e The <Name of user> Properties dialog box opens.

Changing user rights on the database server
4. Inthe <Name of user> Properties dialog box, activate the Generaltab.

5. Click the Server button.
o The Add New Database Server User dialog box opens.

6. Change the current user rights in the DBMS. To do this, select or clear the Allow
user to create new users and/or the Allow user to create new databases check
box.

7. Close all open dialog boxes with OK.

Setting up and editing a user group in a database

Setting up a new user group in a database
1. Use the Database > Administration > User Accounts command.

o The User Accounts dialog box opens.

2. Click the Add Group button.
e The New User Group dialog box opens.

3. Onthe Generaltab, enter the name of the user group and, if required, a
description.
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4. Gotothe Memberstab. Since the new user group doesn't yet have any members,
click the Add button.

5. Inthe Add User dialog box, select a user who is to belong to the new user group,
then click the Add button.

o The user you've added will appear on the Members tab.

6. Ifrequired, click the Add button again, then select another user who is to belong to
the new user group in the Add User dialog box.

Note: Since you are the database administrator, we recommend that you also add
yourself to all of the user groups you set up. Only in this way can you be certain that
you'll always be shown all of the records that the database contains.

7. Click the OK button to finalize the definition of the new user group, and to close the
User Accounts dialog box.

Changing the members of a user group at a later point in time
1. Use the Database > Administration > User Accounts command.

2. Select the user group you want to change, then click the Properties button.

3. Switch to the Group Membership tab and make the required changes there.
00326

-48-



OLYMPUS

www.olympus-global.com

Manufactured by

OLYMPUS CORPORATION
Shinjuku Monolith, 2-3-1 Nishi-Shinjuku, Shinjuku-ku, Tokyo 163-0914, Japan

Distributed by
OLYMPUS EUROPA SE & CO. KG

Wendenstrasse 14-18, 20097 Hamburg, Germany

OLYMPUS CORPORATION OF THE AMERICAS

3500 Corporate Parkway, P.O. Box 610, Center Valley, PA 18034-0610, US.A.

OLYMPUS CORPORATION OF ASIA PACIFIC LIMITED

Level 26, Tower 1, Kowloon Commerce Centre, No.51 Kwai Cheong Road, Kwai Chung, New Territories, Hong Kong

OLYMPUS AUSTRALIA PTY LTD

3 Acacia Place, Notting Hill, 3168, Australia

UMA_Database_cellSens_en



	1.  Overview - Database
	2.  The user interface
	2.1.   Tool Window - Database
	2.2.   Gallery View
	2.3.   Tree View
	2.4.   Record Details View
	2.5.   Search View

	3.  Working with a database
	3.1.   Opening a database
	3.2.   Inserting data into a database
	3.3.   Searching for records
	3.4.   Loading documents from a database
	3.5.   Processing the documents from a database
	3.6.   Moving documents within a database
	3.7.   Importing and exporting data

	4.  Administrating the database
	4.1.   File storage in a database
	4.2.   Setting up a new database
	4.3.   Changing the database view
	4.4.   Managing user rights


